UBCD4Win Forums: Adding Memtest86+ v2.01 and PartedMagic 3.2 - UBCD4Win Forums

Jump to content

  • (2 Pages)
  • +
  • 1
  • 2
  • You cannot start a new topic
  • You cannot reply to this topic

Adding Memtest86+ v2.01 and PartedMagic 3.2 Any sucess in adding these to UBCD for Win?

#1 User is offline   PsiMoon314 Icon

  • Newbie
  • Pip
    • Group: Members
    • Posts: 24
    • Joined: 12-April 05

    Post icon  Posted 18 November 2008 - 05:56 AM

    Hi,

    Has anyone had any success adding Memtest86+ v2.01 or PartedMagic v3.2 to the UBCD for Windows boot menu?

    This would appear in the text menn before booting UBCD itself.

    Memtest86+ is part of UBCD for DOS so that is one way to get to it now, and PartedMagic will be part of the next release of UBCD for DOS but for now it would be nice to add them to the UBCD for Windows boot menu to speed things up a bit.

    Kind Regards

    Simon
    0

    #2 User is offline   homes32 Icon

    • Member
    • PipPip
      • Group: Members
      • Posts: 81
      • Joined: 07-December 07
      • Location:Minnesota, USA

      Posted 18 November 2008 - 10:07 AM

      View PostPsiMoon314, on Nov 18 2008, 05:56 AM, said:

      Hi,

      Has anyone had any success adding Memtest86+ v2.01 or PartedMagic v3.2 to the UBCD for Windows boot menu?

      This would appear in the text menn before booting UBCD itself.

      Memtest86+ is part of UBCD for DOS so that is one way to get to it now, and PartedMagic will be part of the next release of UBCD for DOS but for now it would be nice to add them to the UBCD for Windows boot menu to speed things up a bit.

      Kind Regards

      Simon

      you should probably read the list of tools before you post asking for a program. Memtest86+ is included in the Multiboot menu.

      you can create a plugin for parted magic by following the instructions here
      good luck!

      -homes32
      0

      #3 User is offline   SteelTrepid Icon

      • Administrator
      • PipPipPipPipPipPipPipPip
        • Group: Admin
        • Posts: 6,191
        • Joined: 27-April 04
        • Gender:Male
        • Location:Ohio

        Posted 18 November 2008 - 10:45 AM

        Well the only bad thing with that advice, my lack of updating the page.

        I've honestly put it off for the past few releases so the page really isn't up to date. I'll try to get it updated throughout the week, this week should be good because we aren't that busy right now and Tracy is back from all his funerals.
        "I play Russian roulette everyday, a man's sport, with a bullet called life"

        "My cause is noble, my power is pure"
        0

        #4 User is offline   cdob Icon

        • Special Guest
        • PipPipPipPipPipPip
          • Group: Moderator & Development
          • Posts: 1,434
          • Joined: 19-October 05

          Posted 18 November 2008 - 03:03 PM

          View PostPsiMoon314, on Nov 18 2008, 05:56 AM, said:

          Memtest86+ v2.01

          There is Memtest86+ V2.10 (15/11/2008) too.
          Replace file UBCD4Win\plugin\Multiboot-003\memtest86\memtest.img.
          Use 1.44kb floppy image.
          0

          #5 User is offline   DM2K Icon

          • Newbie
          • Pip
            • Group: BETA Tester
            • Posts: 18
            • Joined: 10-December 07
            • Location:The Dark Places

            Posted 02 December 2008 - 10:14 AM

            I have been working with UBCD4Win for several years now and use it daily as part of my job.
            The tools on it & that I have added to it save me tons of time.
            So far from trolling the many forums that are available I have been able to get all the tools
            I use to work on both DVD & USB versions of the UBCD4Win.
            Only the most recent versions of PartedMagic 3.0 - 3.2 I have not been able to get to work.

            If anyone is able to get it to work on both a disk (CD or DVD) format & a USB flash drive please post the
            entire how to with what lines are in your syslinux.cfg file. I would like to stick with syslinux because I have
            all my other boot tools working with it right now & really do not want to change over the 40+ applications I use
            to grub4dos if I do not have to. I have tried all the different suggestions I have read in this forum, but so far
            none have worked with PartedMagic 3.2.
            "Never underestimate the power of human stupidity. "Robert A. Heinlein
            0

            #6 User is offline   cdob Icon

            • Special Guest
            • PipPipPipPipPipPip
              • Group: Moderator & Development
              • Posts: 1,434
              • Joined: 19-October 05

              Posted 02 December 2008 - 05:10 PM

              @DM2K
              Try the pmagic-usb-3.2 release for USB hardware.
              There is a syslinux.cfg included already, copy and past all label parts.
              0

              #7 User is offline   DM2K Icon

              • Newbie
              • Pip
                • Group: BETA Tester
                • Posts: 18
                • Joined: 10-December 07
                • Location:The Dark Places

                Posted 02 December 2008 - 05:29 PM

                Tried that.
                It gets most of the way through then gives the following error.

                [email protected]:/# splashy caught signal error number. Exiting... splashy caught signal error number. Exiting...

                This is a real system not a VM or other emulated environment.

                I made the USB version of Parted Magic 3.2 on a separate USB drive following the directions on the Wiki and that works
                with no problems. I made sure I was using the newest syslinux as he mention in his forums. Systems I have tried it on all
                have over the 300 MB he suggests.

                I think that something is missing, but I am unable to determine if it is calling on something that is not there or what.
                "Never underestimate the power of human stupidity. "Robert A. Heinlein
                0

                #8 User is offline   DM2K Icon

                • Newbie
                • Pip
                  • Group: BETA Tester
                  • Posts: 18
                  • Joined: 10-December 07
                  • Location:The Dark Places

                  Posted 02 December 2008 - 09:11 PM

                  Just noticed I missed something in my post.
                  The correct error is:

                  root[email protected]:/# splashy caught signal error number 6. Exiting... splashy caught signal error number 6. Exiting...

                  I doubt this changes anything, but there you are.
                  "Never underestimate the power of human stupidity. "Robert A. Heinlein
                  0

                  #9 User is offline   Jotnar Icon

                  • Ultimate Member
                  • PipPipPipPipPip
                    • Group: Members
                    • Posts: 980
                    • Joined: 25-August 04

                    Posted 03 December 2008 - 08:31 AM

                    Try the PXE version. I've had better luck with that since the whole thing is only in a few files.

                    Cheers
                    0

                    #10 User is offline   cdob Icon

                    • Special Guest
                    • PipPipPipPipPipPip
                      • Group: Moderator & Development
                      • Posts: 1,434
                      • Joined: 19-October 05

                      Posted 03 December 2008 - 10:14 AM

                      View PostDM2K, on Dec 2 2008, 06:29 PM, said:

                      I made the USB version of Parted Magic 3.2 on a separate USB drive following the directions on the Wiki and that works with no problems.

                      Just tried myself, yes USB version of Parted Magic 3.2 does work at USB hardware with syslinux.

                      Quote

                      I made sure I was using the newest syslinux as he mention in his forums. Systems I have tried it on all
                      have over the 300 MB he suggests.

                      I don't undertand. Do you have a link?
                      Which USB hardware do you use?
                      Which partitions and format do you use?
                      0

                      #11 User is offline   DM2K Icon

                      • Newbie
                      • Pip
                        • Group: BETA Tester
                        • Posts: 18
                        • Joined: 10-December 07
                        • Location:The Dark Places

                        Posted 03 December 2008 - 10:54 AM

                        Link in the Parted Magic Forum for Memory amount.

                        http://forums.parted...ic.php?f=2&t=22

                        Link for syslinux info.

                        http://forums.parted...ic.php?f=2&t=23

                        I am using several 2 Gb SanDisk Cruzer Micros formatted FAT 16x & FAT 32x for my trials so far
                        as a single partition.
                        "Never underestimate the power of human stupidity. "Robert A. Heinlein
                        0

                        #12 User is offline   DM2K Icon

                        • Newbie
                        • Pip
                          • Group: BETA Tester
                          • Posts: 18
                          • Joined: 10-December 07
                          • Location:The Dark Places

                          Posted 03 December 2008 - 11:51 PM

                          Well after talking to the person who makes Parted Magic (Patrick Verner) in the forums on his site, he was able
                          make the corrections needed to the syslinux.cfg file to allow the program to work properly.
                          The addition was simple, but now I am paring out what is not needed & will post what I did shortly
                          in a new post in this forum. But for right now I can say it works fine with what has been done so far.
                          "Never underestimate the power of human stupidity. "Robert A. Heinlein
                          0

                          #13 User is offline   cdob Icon

                          • Special Guest
                          • PipPipPipPipPipPip
                            • Group: Moderator & Development
                            • Posts: 1,434
                            • Joined: 19-October 05

                            Posted 04 December 2008 - 03:50 PM

                            http://forums.parted...ic.php?f=2&t=35

                            Quote

                            Mostly I am putting stuff in this directory structure.
                            root/syslinux/images/parted/ "everything from the USB version"

                            Well, relocating files is asking for errors.

                            As for a first try:
                            copy USB version root directory to root directory at USB drive.

                            Or adjust syslinux.cfg as Patrick Verner pointed out:
                            directory=/syslinux/images/parted/
                            0

                            #14 User is offline   DM2K Icon

                            • Newbie
                            • Pip
                              • Group: BETA Tester
                              • Posts: 18
                              • Joined: 10-December 07
                              • Location:The Dark Places

                              Posted 04 December 2008 - 05:10 PM

                              As that is from my discussion with him I got it working after moving and redoing my syslinux.cfg file.
                              Putting everything in root had some conflicts so it was better in the end to have everything moved.
                              My USB for parted magic 3.2 works fine now. Soon I am going to do my CD/DVD versions up.
                              I doubt I will have much trouble with that compared to the USB. :clapping:

                              Admittedly I am not very good with linux or coding in general, but as I have been using these tools
                              and configuring them and mostly digging in forums to find answers for a few years now. It is nice
                              to see that most people are willing to help each other out here.

                              This post has been edited by DM2K: 04 December 2008 - 05:36 PM

                              "Never underestimate the power of human stupidity. "Robert A. Heinlein
                              0

                              #15 User is offline   cdob Icon

                              • Special Guest
                              • PipPipPipPipPipPip
                                • Group: Moderator & Development
                                • Posts: 1,434
                                • Joined: 19-October 05

                                Posted 04 December 2008 - 05:27 PM

                                View PostDM2K, on Dec 4 2008, 05:10 PM, said:

                                Soon I am going to do my CD/DVD versions up.

                                /directory seems to work at CD/DVD too
                                http://www.ubcd4win.com/...p...ost&p=62903
                                0

                                • (2 Pages)
                                • +
                                • 1
                                • 2
                                • You cannot start a new topic
                                • You cannot reply to this topic

                                1 User(s) are reading this topic
                                0 members, 1 guests, 0 anonymous users