UBCD4Win Forums: Vista System Files "access Is Denied" - UBCD4Win Forums

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

Vista System Files "access Is Denied"

#1 User is offline   Powel Icon

  • Newbie
  • Pip
    • Group: Members
    • Posts: 4
    • Joined: 09-November 09

    Posted 09 November 2009 - 09:25 PM

    Hello,

    Sorry if this is posted in the wrong forum or if this is a dumb Noob question.
    I has a Vista Pc that will not boot and I am trying to recover my .PST file, I created a bootCD with UBCD4win 3.50
    and it all works great but I am unable to access any of Vista's Local settings or application data.
    I always get "access is denied" If I does a search with agent ransack no PST file is found.
    How do get permission to access these files ?

    Thanks
    0

    #2 User is offline   cdob Icon

    • Special Guest
    • PipPipPipPipPipPip
      • Group: Moderator & Development
      • Posts: 1,434
      • Joined: 19-October 05

      Posted 10 November 2009 - 05:27 AM

      Understanding Windows NTFS Permissions
      http://www.windowsec...ermissions.html
      0

      #3 User is offline   Powel Icon

      • Newbie
      • Pip
        • Group: Members
        • Posts: 4
        • Joined: 09-November 09

        Posted 10 November 2009 - 11:38 AM

        I knew that was probably the issue but could not find any way to change premissions from the UBCD
        Can it be done ?
        0

        #4 User is offline   cdob Icon

        • Special Guest
        • PipPipPipPipPipPip
          • Group: Moderator & Development
          • Posts: 1,434
          • Joined: 19-October 05

          Posted 10 November 2009 - 11:59 AM

          Run explorer, open security tab, take ownership, change permission.
          0

          #5 User is offline   Powel Icon

          • Newbie
          • Pip
            • Group: Members
            • Posts: 4
            • Joined: 09-November 09

            Posted 10 November 2009 - 01:54 PM

            View Postcdob, on 10 November 2009 - 08:59 AM, said:

            Run explorer, open security tab, take ownership, change permission.



            I have tried that and it made no difference, it also looks like the permissions are preset
            for full access
            0

            #6 User is offline   cdob Icon

            • Special Guest
            • PipPipPipPipPipPip
              • Group: Moderator & Development
              • Posts: 1,434
              • Joined: 19-October 05

              Posted 10 November 2009 - 02:28 PM

              PE use system account. System has to have NTFS permission.

              Which file do you like to open? Name the full path.

              Remember there is no directory "Documents and Settings" at Vista, there is a directory "Users" by default.
              0

              #7 User is online   pcuser Icon

              • Project Programmer
              • PipPipPipPipPipPipPip
                • Group: Moderator & Development
                • Posts: 3,889
                • Joined: 20-November 04
                • Gender:Male
                • Location:Kneebrasskee

                Posted 10 November 2009 - 03:07 PM

                You can also use SubInACL:

                subinacl /subdirectories "C:\*.*" /grant=administrators=f 
                
                subinacl /subdirectories "C:\*.*" /grant=system=f 
                


                Change C:\ to the path where your files are. It might be a good idea to run chkdsk if you haven't already.
                If you're afraid of taking any chances then the chances are great that you will never learn anything

                Multiboot Plugins - UBUSB (Ultimate Boot USB) - EzPcFix - RootKitty - Network Configuration Utility - UnIsoFS - A Small Linux Distro - SELogger - HashME - WSock - My Paypal
                0

                #8 User is offline   Powel Icon

                • Newbie
                • Pip
                  • Group: Members
                  • Posts: 4
                  • Joined: 09-November 09

                  Posted 10 November 2009 - 10:19 PM

                  I got it figured out chkdsk seemed to make the difference.I think my HD may be toast.

                  Thanks for all the help
                  0

                  #9 User is offline   Lord Necron Icon

                  • Member
                  • PipPip
                    • Group: Members
                    • Posts: 32
                    • Joined: 12-August 09
                    • Gender:Male
                    • Location:USA

                    Posted 10 November 2009 - 11:32 PM

                    View PostPowel, on 10 November 2009 - 09:19 PM, said:

                    I got it figured out chkdsk seemed to make the difference.I think my HD may be toast.

                    Thanks for all the help

                    HDAT would let you know how bad it is. CHKDSK just means a corrupt file system, which doesn't always mean a bad drive...
                    Posted Image
                    Posted Image
                    Posted Image
                    0

                    Page 1 of 1
                    • You cannot start a new topic
                    • You cannot reply to this topic

                    1 User(s) are reading this topic
                    0 members, 1 guests, 0 anonymous users