UBCD4Win Forums: Hemo2 - Viewing Profile

Jump to content

Hemo2's Profile User Rating: -----

Reputation: 0 Neutral
Group:
Members
Active Posts:
115 (0.05 per day)
Most Active In:
General Questions (45 posts)
Joined:
13-August 04
Profile Views:
8368
Last Active:
User is offlineOct 14 2010 07:44 AM
Currently:
Offline
Icon   Hemo2 has not set their status

Posts I've Made

  1. In Topic: Usb Boot "Offline Nt Password & Registry Editor"

    Posted 8 Oct 2010

    Thanks cdob. The entries to boot the .iso image does work from the thumbdrive, so that's the route I'll take. It will be nice to have this bootdisk available on both the boot CD and USB thumbdrive that our techs use!
  2. In Topic: Usb Boot "Offline Nt Password & Registry Editor"

    Posted 6 Oct 2010

    Thanks cdob. I downloaded the latest 0.4.5.b version, but unfortunately it still doesn't work from a thumb drive.

    Just to be clear, I build the UBCD4Win and burn the .ISO to a CD and this works fine and I was able to reset the local admin password on a Win7 - 64-bit pc, thus the reason we'd really like to get this to run off the thumbdrive as not every pc has a CD Drive anymore. The CD not only boots fine and the Offline NT Password bootdisk comes up fine, but the Offline NT Password bootdisk also loads hard disk drivers during it's boot process. You know it's loaded the drivers because after it boots it shows you the available potential Windows partitions it finds. I assume these drivers are coming from that "scsi.cgz" file that gets passed to the pnordahl.cgz boot image and this works fine when booting from the CD, which uses a different way to bootup than the thumbdrive does.

    When I then run UBUSB.EXE that comes with the UBCD4Win project to make a bootable USB thumbdrive, I format my thumbdrive as Fat32-LBA with a boot loader of Grub4dos. When it's finished, I replace the CONFIG.SYS with customized one that gives us multiple menus options to choose from. To load the Offline NT Password & Registry Editor, I have the commands an "others.lst" menu file.

    [OTHER]
    DEVICE=HIMEM.SYS
    DOS=HIGH
    FILES=60
    BUFFERS=30
    device=grub.exe --config-file=/other.lst


    Inside the "other.lst" menu file, I'm trying to use the below command to bootup the Offline NT Password bootdisk.

    title Offline Password & Registry Editor
    kernel /isolinux/pnordahl rw vga=1  init=/linuxrc
    initrd /isolinux/pnordahl.cgz /isolinux/scsi.cgz


    I initially tried it using a comma to split the two .cgz filenames, but that doesn't work as you get a "file not found" error. Using the above commands does actually boot up the Offline NT Password bootdisk just fine. The problem though is it doesn't appear to load any hard disk storage drivers. I say this because when the message comes up about the potential Windows partitions it finds, it's blank and no partitions are found, thus you can't select the Windows partition to reset the password. This is the problem I'm running into and was hoping that someone else succesfully is booting this particular bootdisk from their thumbdrive using grub4dos.

    I suspect it's not necessarily the version of grub4dos anymore that is the issue, but my complete lack of knowledge on how to properly tell it to load this scenario. All the examples I've found only reference loading a single image file with that "initrd" command and can't find any examples to address the issue like this Offline NT Password bootdisk presents where it apparently somehow needs the second "scsi.cgz" file to get loaded or 'passed' to the first image file to use for the drivers.

    At this point, I've randomly tried a variety of syntax's but it's clear to me I don't understand this. I was able to "jerry rig" the newer Gparted bootdisk into working, but this one has me beat.

    I really appreciate the replies here though and want to thank you very much for your help and info. I'll keep an eye out on this thread in case some kind sole has already accomplished what I'm trying and can share their Grub4dos menu entry.
  3. In Topic: Usb Boot "Offline Nt Password & Registry Editor"

    Posted 6 Oct 2010

    I checked and the grub4dos is the grub.exe from the 0.4.4 version. The UBUSB.exe is the one that came with UBCD4WIN 3.60 and shows version 1.0.51 when I run it.

    It's like the scsi.cgz file is being passed as a parameter to the pnordahl.cgz image to use for the hard disk drivers. I suspect either grub4dos won't work or maybe even more probable is that I just don't know how to enter the syntax properly so it will work. I'm basically just trying different syntax to get it to work and so far no luck.
  4. In Topic: Usb Boot "Offline Nt Password & Registry Editor"

    Posted 5 Oct 2010

    Thanks for the reply pcuser. I don't get the error anymore, but it doesn't seem to load the disk drivers, just as if I left off the "/isolinux/scsi.cgz" part altogether. Not quite sure what else I can try for this, but it does work when booting from a CD, so we can use that format for now.
  5. In Topic: GParted plugin

    Posted 16 May 2008

    No problem pcuser. I had noticed they showed they fixed a bug that prevented working on partitions greater than or equal to 1TB, but we don't currently have any drives that size that we work on so it's fine to wait until it works out for you or someone else to look at this. Thanks.

My Information

Member Title:
Regular Member
Age:
Age Unknown
Birthday:
Birthday Unknown
Gender:

Contact Information

E-mail:
Click here to e-mail me